Click Account get "An error occurred on the server when processing your request."

Apr 20, 2013 at 10:34 PM
I just installed nearforums on my website, version 8.5.3.0. So far it looks great! Only 1 problem, when I click on Account near the top right corner, I get "An error occurred on the server when processing your request. The error detail was sent to our support team." Any clue how to fix this?

Thanks!
Jean
Coordinator
Apr 21, 2013 at 12:31 PM
Hi,
Could you set the customErrors to Off in the web.config to see the full error detail?
<customErrors mode="Off" />
Have you installed Nearforums from the release?
Kind Regards,
Jorge
Apr 21, 2013 at 4:17 PM
Hi Jorge, thanks for the reply. Sorry, I should have done the web config thing from the start. I installed from my webhost provider, arvixe, which I believe was 8.5. I had problems logging in with twitter, and I saw you answer this same problem for someone else, telling them to update their bin folder with the latest 8.5.3. I did this, which fixed the twitter problem, but then encountered this error (not sure if it was there before the .3 patch). Here is the full error:
Description: An error occurred during the compilation of a resource required to service this request. Please review the following specific error details and modify your source code appropriately. 

Compiler Error Message: CS1061: 'NearForums.Web.State.UserState' does not contain a definition for 'Provider' and no extension method 'Provider' accepting a first argument of type 'NearForums.Web.State.UserState' could be found (are you missing a using directive or an assembly reference?)

Source Error:


Line 41:         @Html.TextBox("website", null, new { @class = "text" })
Line 42:    </div>
Line 43:    @if (User.Provider == AuthenticationProvider.Membership)
Line 44:    {
Line 45:        <p class="button"><input type="button" class="button" value="@T("Change Password")" onclick="window.location.href='@Url.Action("ChangePassword", "FormsAuthentication", new { returnUrl = this.Request.Url.PathAndQuery })';" /></p>

Source File: <snip>\forum\Views\Users\Edit.cshtml    Line: 43 
Thank you!
Coordinator
Apr 22, 2013 at 2:39 PM
Hi,
Thanks for the full detail, sorry I didn't reply earlier (monday / back to the office / etc) :)
You should also copy the file Edit.cshtml located on the folder /Views/Users/ from the latest release.

Kind Regards,
Jorge
Apr 22, 2013 at 6:41 PM
That did the trick, thanks so much!

Jean