3
Vote

TopicCreationDate does not belong ot table .

description

I just downloaded the latest source code and have been trying to set up the forum on my test server but it seems like there might be a code bug.

In ForumDataAccess.cs on line 20 we run var dt = GetTable(comm); which runs the sproc SPFforumsGetByCategory. This returns the following rows:
ForumId, ForumShortName, ForumDescription, UserId, ForumCreationDate, ForumTopicCount, ForumMessageCount, CategoryId, CategoryName.

Following it down a few lines we run through a foreach that iterates over DataRows in the table and then on line 32 we do this; Forum f = ParseForumWithTopicDataRow(dr); This function is where the problem is.

This function found on line 74 expects the following rows:
UserId, UserName, TopicId, TopicCreationDate, TopicTitle, TopicShortName

However those are not the rows loaded into the dr when that function is called on line 32.

Anyone else run into this problem??

BTW, This is the source file I'm using nearforums-9f726edbf6c0.zip

comments

Rich_B wrote Oct 21, 2013 at 9:11 PM

I am experiencing the same problem.

Azsael wrote Oct 30, 2013 at 11:04 PM

Hey hey,

I'm assuming you grabbed the master branch, but only ran the version 9 scripts?

Your missing a few script updates, particularly this one would be this one: https://nearforums.codeplex.com/SourceControl/latest#db/scripts/mssql.0057.alter-proc-forum-get-by-category.sql but your most likely missing more.

Your likely going to need to update your database to latest scripts, however I am not sure how you generated the structure.

rdelacalle wrote Jun 30, 2014 at 4:59 PM

Hello there..

I´m having the same problem with MySQL, I generate the structure from file

\db\export\mysql\mysql.nearforums-db

I try to execute the scripts but it was an error due to those scripts are SQL ones.

What should I do to get it running?

Thanks.