Errors when building the solution

Jan 12, 2011 at 7:33 PM

I am receiving several errors when i try to build the solution.

 

Error 2 Cannot apply indexing with [] to an expression of type 'System.Web.Mvc.IValueProvider' C:\Projects\Visual Studio 2010\Projects\NearForum\source-code\NearForums.Web\Modules\ModelBinderModule.cs 33 8 NearForums.Web

Error 3 Cannot apply indexing with [] to an expression of type 'System.Web.Mvc.IValueProvider' C:\Projects\Visual Studio 2010\Projects\NearForum\source-code\NearForums.Web\Modules\ModelBinderModule.cs 35 29 NearForums.Web

Error 4 Cannot apply indexing with [] to an expression of type 'System.Web.Mvc.IValueProvider' C:\Projects\Visual Studio 2010\Projects\NearForum\source-code\NearForums.Web\Modules\ModelBinderModule.cs 36 95 NearForums.Web

Error 5 Cannot implicitly convert type 'System.Web.Mvc.MvcHtmlString' to 'string' C:\Projects\Visual Studio 2010\Projects\NearForum\source-code\NearForums.Web\Extensions\HtmlExtensions.cs 78 11 NearForums.Web

Error 6 Cannot implicitly convert type 'System.Web.Mvc.MvcHtmlString' to 'string' C:\Projects\Visual Studio 2010\Projects\NearForum\source-code\NearForums.Web\Extensions\HtmlExtensions.cs 156 11 NearForums.Web

Error 7 Cannot implicitly convert type 'System.Web.Mvc.MvcHtmlString' to 'string' C:\Projects\Visual Studio 2010\Projects\NearForum\source-code\NearForums.Web\Extensions\PagerExtensions.cs 222 11 NearForums.Web

 

Any ideas?

Coordinator
Jan 13, 2011 at 9:33 AM

Hi,

It seems that you are targeting ASP.NET MVC version 2, instead of ASP.NET MVC 1. 

The solution should target Framework 3.5 and ASP.NET MVC 1.

Hope it helps,

Kind Regards,

Jorge

Coordinator
Jan 13, 2011 at 11:50 AM

More info on the Framework / MVC support...

We are discussing to upgrade to MVC 3 (.NET 4/Mono 2.8) once it's on RTM... using Razor as view engine. (Would you like to be part in this upgrade/migration?)