MySQL installation

Dec 16, 2012 at 9:54 PM

Hi. I am importing mysql.nearforums-db.sql (from Nearforums v8.5 zip download) into new MySQL database using phpmyadmin (using import tool).
I am getting following error:


SQL query: 
delimiter ; ;
/*!50003 create*//*!50003 procedure spusersgetbyname( param_username nvarchar(50) ) begin select u.userid ,u.username ,u.userprofile ,u.usersignature ,u.usergroupid ,u.userbirthdate ,u.userwebsite ,u.usertimezone ,u.userphoto ,u.userregistrationdate ,ug.usergroupid ,ug.usergroupname from users u inner join usersgroups ug on ug.usergroupid = u.usergroupid where u.username like concat('%', param_username, '%') and u.active = 1 order by u.username; end */ ; ;

MySQL said: 
#1064 - You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'create*/ /*!50003 procedure spusersgetbyname(  param_username nvarchar(50) ) ' at line 1 

 

I have MySQL server version 5.5.28 and phpMyAdmin 3.3.1.

Coordinator
Dec 17, 2012 at 11:02 AM

Hi,

Apparently phpMyAdmin has problems on conditional expressions...

Can you access mysql from the shell? If so, execute

mysql -u username -p password database_name < file.sql

 

We could create a script to "strip" all this conditional expressions... but it will take us some time...

 

Kind regards,

Jorge

Jan 23, 2013 at 12:39 PM

Hi,

I am facing similar issue but error is shown at different line, and I don't have access from the shell.

Can you please provide the script without conditional formatting that can work with phpMyAdmin.

Regards,

Lokin Shah

May 14, 2013 at 8:07 PM
I get the same error. Don't think I will get access from a shell because im not hosting the site myself.
May 14, 2013 at 9:15 PM
Fixed it by using a remote tool to access the server.